Cubeuser.de - Das Cube & Power PC Forum

Cubeuser.de - Das Cube & Power PC Forum (https://www.cubeuser.de/index.php)
-   Windows & andere OSs (https://www.cubeuser.de/forumdisplay.php?f=128)
-   -   Dual-Boot Debian und Mac OS X (https://www.cubeuser.de/showthread.php?t=2553)

Fabster 09.10.2016 09:06

Dual-Boot Debian und Mac OS X
 
Hallo in die Runde,
ich sitze gerade neben meinem alten G5 1,8 GHz und versuche mich an Debian. Bislang habe ich Linux nur auf einem iBook oder dem Cube versucht und da ist das meist auch kein Problem: eine Platte platt gemacht, Mac OS X installieren, eine Partition frei lassen, Linux installieren, fertig. Über yaboot lässt sich dann Linux oder Mac OS X auswählen. So weit so gut.
Ich sitze nun an einem Rechner mit zwei Platten (Samsung und Maxtor). Auf der Samsung-Platte ist Mac OS X drauf und das soll so auch bleiben. Auf der Maxtor soll Debian 8.6 drauf.
Ich bin mal den offensichtlichen Weg gegangen: Debian Net-Installation starten, Maxtorplatte als Zielplatte ausgewählt, Debian partitioniert sich das Ding hin, installiert sich, fertig.
Ich starte den Rechner hoch: kein yaboot-Auswahlmenü. Das ist klar, weil der Rechner ja von der Samsung bootet. Als Startvolumes in Mac OS X zeigt er mir aber außer der Net-Installation nur die Samsung-Platte an. Also neu gestartet und <alt> gedrückt. Es erscheint der Auswahlbildschirm wo eine Mac- und eine Linux-Startpartition angewählt werden können. Sehr gut. Läuft ja wie erwartet. Ich klicke auf die Linux-Platte und yaboot kommt hoch. Auswahlmöglichkeit Linux, Mac OS X, CD-Rom. Ich drücke l für Linux und lande... beim Auswahlbildschirm von vorhin. Ich wähle die Linux-Partition aus. Yaboot folgt. Ich drücke l. Lande wieder beim Auswahlbildschirm. X für Mac OS X drücken bewirkt das gleiche.

Was habe ich falsch gemacht?

(Derweil installiert sich Debian auf der Maxtor-Platte und die Samsung-Platte ist abgestöpselt. Ist kein Zustand, aber ich will Debian erst einmal ausprobieren, bevor das zum Dauerzustand werden kann.)

Acid Burn 09.10.2016 09:59

Ich würde so vorgehen: die Linux Platte als erste Platte am IDE. Die Mac Platte am zweiten IDE bzw. als Slave am ersten IDE Port. Weiß jetzt nicht, wie du das gemacht hast. Dann sollte normal die Linux Platte standardmäßig als Erste hochfahren. Ohne was zu wählen sollte Linux komplett dann hochfahren. Willst du OS X, kannst du dann beim Hochfahren in Yaboot die Mac Platte wählen.

Fabster 09.10.2016 10:06

Genau das war es! Maxtor-Platte in den oberen Schacht und es klappt. Merci!

Jetzt hab ich nur ein Problem mit der Grafikkarte! *aahhh!*

Acid Burn 09.10.2016 11:04

Unter Linux oder OS X?

steffensam 09.10.2016 11:30

Das Problem hatte ich auch, auf meinen G5.
Auch das wechseln von NVIDIA auf ATI brachte keine Besserung.

Acid Burn 09.10.2016 11:31

Zitat:

Zitat von Fabster (Beitrag 44908)
Genau das war es! Maxtor-Platte in den oberen Schacht und es klappt. Merci!

Jetzt hab ich nur ein Problem mit der Grafikkarte! *aahhh!*

Wenn du Probleme mit der Graka hast, macht es Sinn, hier im Ubuntu Forum einige Fred´s zu lesen.

Fabster 09.10.2016 13:08

Ja, dank, für den Link. Muss ich mir mal anschauen. Das Problem ist: die Standard-Installation von Debian erstellt einen Root-Nutzer und einen normalen Nutzer. Aufgrund der NVIDIA-Karte und dem fehlenden/fehlerhaften Treiber bleibt das Apple-Display schwarz. Debian startet allerdings hoch. Ich kann mich als normaler Nutzer per ssh einloggen, kann aber sudo nicht nutzen. Als root kann ich mich per ssh nicht einloggen, weil das standardmäßig ausgeschaltet ist. Jetzt installiere ich im Expert-Modus, was wesentlich aufwendiger ist, dafür kann mein normaler Nutzer dann wenigstens sudo verwenden. Ohne das kann ich mich gar nicht an die Fehlerbehebung begeben.

Fabster 09.10.2016 13:09

... und was ich bisher gelesen habe, wegen dem Treiber-Problem produziert bei mir bislang nur Fragezeichen...

Acid Burn 09.10.2016 13:12

Versuche doch mal statt Debian eine *buntu Variante, bevorzugt 12.04 respektive 12.10. Zum Testen besser geeignet. Alles was danach kam war nur noch buggy

Fabster 09.10.2016 13:24

Mit Ubuntu hatte ich bislang nur Probleme. Das scheiterte meist schon an der Installation. Weiter als zum Login-Screen kam ich selten. Wobei: Ubuntu 12 habe ich glaube ich noch nie probiert.
Aber: Debian 8.6 läuft ziemlich anständig auf meinem Mac Mini! Zumindest LXDE und Xfce, und letzteres ist genau mein Geschmack. :) Ich schau jetzt mal, dass ich mich zumindest mit ssh einloggen kann, dann probiere ich mal ganz stur diese Hilfestellung oder die.


Alle Zeitangaben in WEZ +2. Es ist jetzt 00:35 Uhr.

Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.


Copyright © 2008 - 2019 - Cubeuser.de - PPC-Forum.de - PowerPC-Forum.de

Cubeuser.de ist kein offizielles oder in irgendeiner Form anerkanntes Forum von Apple.
Apple, Cube, Mac etc. sind eingetragene Markenzeichen von Apple Inc. - Cupertino, CA - USA

Cubeuser.de ist eine unabhängige private (nicht gewerbliche) Online-Plattform von und für User um sich gegenseitig bei Problemen auszutauschen oder zu helfen.
Cubeuser.de ist nicht verantwortlich für die Beiträge einzelner User, rechtswidrige Beiträge werden jedoch sofort nach Erkennen oder nach Hinweis Dritter gelöscht.